"Adapt to grammar only" in tables

Signature block: the snippet “party1-np-gender” includes the concept “party-title-male” with the concept label “de heer” in Dutch for which the capitalization is set to “adapt to grammar only”. So it should be “De heer” in the beginning of a sentence, but a row in a table is not treated as the beginning of a sentence, correct?

|| @#party1-np-gender #party1^name || @#party2-np-gender #party2^name ||

Hi Bernd,

“Grammar” actually refers to the way a concept is written in the ClauseBase grammar , i.e. whether you wrote “#party” or “#Party” or “#PARTY” in the clause. It is unrelated to how Dutch grammar dictates when words should be capitalized. (As an aside - we realize the Knowledge Base documentation was not entirely clear on this point, so we will adapt this.)

So if you write “#party”, and set the capitalization of the concept label to “adapt to grammar only”, then the conceptlabel will always show up in small letters — even when the general styling settings would dictate that defined terms should be printed with an initial capital or in all-capitals.

Some additional tips:

  • in this specific case, it would probably be more practical to use conditional text tied to a datafield (e.g. #party2^gender) instead. You could then make two separate snippets, one for situations where the title must be used in the beginning of a sentence (i.e. result in “De heer” / “Mevrouw”) and one for all other situations (resulting in “de heer” / “mevrouw”).
  • setting the capitalization of an individual concept label should be highly exceptional (to be reserved for situations where a specific defined term’s capitalization should be different from the capitalization of all the other defined terms, e.g. for the name of a brand such as “ClauseBase”). You should primarily use the styling settings (subsection “Definitions”) to define the capitalization of your defined terms.
  • if you want to force ClauseBase to use a certain type of capitalisation in one specific place, there are two sets of special functions that can help:

Unless it’s the first word of a sentence, correct?

To give you a bit more context, here is my signature block:

|| {true}                                                            || {true}                                                            ||
|| @#party1-np-gender #party1^name                                   || @#party2-np-gender #party2^name                                   ||  
|| {#party1^natural-person = false: #party1^representative-name}     || {#party2^natural-person = false: #party2^representative-name}     ||  
|| {#party1^natural-person = false: #party1^representative-function} || {#party2^natural-person = false: #party2^representative-function} ||  
|| %signature% Signature:                                            || %signature% Signature:                                            ||

And here is the snippet for @#party1-np-gender (and the snippet for party 2 is mutatis mutandis):

{#party1^natural-person = true : {#party1^male = true: #party-title-male | = false: #party-title-female}}

I cannot change the snippet to #Party-title-male with a capital letter, because then the above sentence in the “parties” clause will result in “De Heer”, but it should always be “de heer”, unless in the beginning of a sentence where it should be “De heer”.

In Dutch, the concept label of #party-title-male is “de heer” with capitalization set to “adapt to grammar only”. That works fine for all clauses (i.e. no capital if not in the first word of a sentence), but it doesn’t work for a table and I think the reason is that ClauseBase doesn’t treat a cell of a table as the beginning of a sentence?

(on a side note: the title of a party could also be “Dr.” in the future, for instance. So, then I could add this as an additional concept label)

ClauseBase does not detect whether a word is the beginning of a sentence - it only follows the instructions inherent to the way the concept label was capitalised in the clause grammar. That means that (assuming default definition styling and unless the capitalisation was set to ‘fixed’) if the concept label was written with an initial capital letter, the resulting text will be capitalised, i.e.: #Supplier will result in “The Supplier”, “A Supplier” and #supplier will result in “the Supplier” or “a Supplier” (based on the settings for the article). This rule applies regardless of whether this concept label was used in the beginning of a sentence or elsewhere.

In practice, that means for your case that a distinction will still have to be made between concept labels that are used in the beginning of a sentence (with the initial letter capitalised, i.e. #Party-title-male) and those used elsewhere (i.e. #party-title-male).

The most practical solution in my view would be to create an additional snippet containing the capitalised concept label(s) so that you have two snippets, one to be used in the beginning of a sentence (including in table cells) and one for all other cases.

I made second snippet, which indeed seems to be the easiest solution in this case. Thanks.