Add an e-mail address as pre-defined answer


If I enter the name of a person as a datafield, its e-mail address should automatically appear.

I used the following formula to do so:
“Lawyer 1 = Tom :” and highlighted everything in cyan.

The mechanism works, but the @ does not appear in ClauseBuddy.
When I un-highlight (is that even a word?) the ‘@’, appears.

How can I solve this please?


Hi Tom,

Welcome to the discussion forum!

You followed the correct reasoning approach, but for technical reasons it will not work like this.

  • In the part after the colon ( : ) of cyan-highlighted text, you must either put plain text, or a Clause9-formula. Unfortunately, when you type “”, MS Word automatically — but silently — converts this into a clickable hyperlink. That clickable hyperlink is no longer plain text, hence the weird things you see in your output.
  • A second reason why this won’t work, is that the “@” symbol has a very special meaning for ClauseBuddy, because it is an indication that you are probably using a Clause9-formula (instead of plain text).

You have two possibilities to solve this:

  • Either move the formula (condition) to the beginning of the paragraph, so that only your condition (Lawyer 1 = Tom) is cyan-highlighted, and the “” is no longer highlighted. ClauseBuddy doesn’t do anything with non-highlighted text, so you are free to enter whatever you want there — including hyperlink-clickable email addresses.

  • If it is not possible, from a legal reasoning point of view, to move the formula to the beginning of the paragraph, then your only option is to use a Clause9 formula within the cyan-highlighted part after the colon ( : ). The correct formula is fairly simple, by the way: @email(“”).

    In this case, do make sure that Word doesn’t silently convert your “” into a clickable hyperlink. If it does (and most MS Word instances do, because that’s the default setting), then immediately press undo (or hit Ctrl-Z) after you see the conversion taking placed on the screen.

The proposed solutions work like a charm! Thanks