Having trouble with a simple "separator" – difficulty with special characters

I feel slightly embarrassed to ask this, but I’m trying to code a body-signature block separator that, in Word, looks like this:

image

The first problem is that Clausebase interprets the first asterisk as a bullet. I can’t see a way around this, other than to use a hyphen or some other character before it, which I don’t want to do.

Also, if I leave 3, 4, or 5 spaces between the asterisks, it’s no different than if I use 2. The rest seem to be ignored. Should I be using tabs somehow between the asterisks?

Finally, I cannot get a square bracket to render as a character.

Is everyone mpressed with how I’ve achieved a zero success rate with this trivial clause?

My syntax right now:

*     *    *
%%
`[signature pages follow]`

Don’t feel embarrassed, it’s one of these typical pitfalls. Which is the reason why we actually used this very example in one of our tutorials: see https://help.clausebase.com/tutorials/tutorial-for-clause-authors/7

1. The main problem is indeed that your paragraph starts with an asterisk (*) which has a special meaning in ClauseBase. One possibility to circumvent this, is to start the paragraph with something else — e.g., in the tutorial we surround the asterisks with tildes (~) to make them bold, which is probably also a good solution for you, because it makes the asterisks a bit nicer even.

Another possibility is to start the paragraph with a special symbol that causes the paragraph to get centered: % align center % * * *

A more general solution, for any situation where you are stuck because you want to use characters that have special meaning in ClauseBase (e.g., the square brackets around your “[signature pages follow]”), is to quote them inside a formula: simply insert {"* * *"}. Within the quoted context, all special symbols (except the closing quotes) lose all their special meaning.

2. For the square brackets: these also have special meaning in ClauseBase. So also here you would have to quote them: {"[signature pages follow]"}

3. You are right that adding more than one space has no effect in ClauseBase. This is actually a feature, not a bug or limitation, because in most situations where you use more than one space, you probably intended to use only one space.

By the way, MS Word’s layout engine expects one-space-only input; weird layout shifting and line breaks in the wrong places can easily happen with multiple consecutive spaces (not in your specific situation, but in many others). In upcoming versions of Word, Microsoft will even flag multiple spaces as errors: https://www.theverge.com/2020/4/24/21234170/microsoft-word-two-spaces-period-error-correction-great-space-debate

If you really need extra spaces between the asterisks, I would suggest to use tab stops around the horizontal center:

@tab(4) * @tab(5) * @tab(6) *

(By the way, because this line starts with a non-asterisk character, it would also resolve your first question.)

4. Once done, it’s probably a good idea to put both the asterisks and the “[signature pages follow]” within an external snippet. This way, you can insert it very quickly in the future.

Thanks!!!

Strange:

This works:

% align center % * * *
% align center % {"[signature pages follow]"}

But if I want to get more space between the asterisks, as you suggest, I do this:

@tab(4) * @tab(5) * @tab(6) *
% align center % {"[signature pages follow]"}

However for some reason, in the latter example, the “signature pages follow” language does not center.

???

Sorry, you seem to have hit a tabstop rendering glitch; it actually works fine when printed. (Due to their fluid rendering intents, browsers cannot actually render tabstops — so ClauseBase has to use quite some browser magic to render tabstops in a browser. There are several situations where this breaks down, e.g. when your screen gets too small, but your situation should have worked; anyway it’s solved now.)

Due to the hoops you have to jump through in this situation — i.e. you actually have to force the platform to do something that it actively tries you to prevent from doing, as it’s the wrong “Word way” — we now added a function @asterisks.

This function inserts the specified number of asterisks, centers the paragraph, and precedes the paragraph with some extra spacing. I hope this helps!

Example:

image