Issue with "Different answer per language" selection


I get the following message when trying to make “Different answer per language” selection in Q&A editor’s Question options popup.

Screenshot 2022-02-17 221217

The condition indeed exists for the question, but I get the same message even if I delete the underlying condition for that question (and save the Q&A).

Am I missing something or is this a bug?

The thing that helps to go around the issue is copying and pasting the same question (deleting the old one) and then making the selection.

Hi Tomas, a bug is always possible, but the internal check is fairly simple from a technical point of view and has always been correct so far.

Can you select the question in one pane of Design Q&A, and check the output of the “Dependencies” pane in the other pane?

Dependencies pane appears empty:


Hi Tomas,

Had a quick look at your file. The problem is that the question you selected, itself contains a condition.

Here’s how you can quickly solve it:

  • Copy the condition in question, so you can later on paste it
  • Remove the condition
  • Save the Q&A
  • Change the “Different answers…” setting
  • Paste the condition again.

This process is a bit cumbersome, I’ll make a note to change it later on. (Toggling the "Different answers… " setting changes the setup of the question, which can easily corrupt other items that somehow refer to it — such as the condition in question. The software is (in this case too) strict in not allowing this, but it avoids data corruption.)

Thanks, Maarten. However, this is exactly what I tried to do, i.e. to delete the condition for that question, save the Q&A, and change the setting, but I still get the message, though there is no condition or other dependencies for that question.

(Solved through private conversation.)

For future reference: the Q&A also needs to be closed before changing the “Different answers… setting”. This appears to be a bug, we will look into this.

Thanks, Maarten, for 24/7 customer service!