Styling of number datafield

Number datafields don’t follow the styling of numbers in the body text.

_7_ hours will result in

seven (7) hours

#concept^number-datafield will result in

7 hours

with the same styling settings.

Is it intended to work like this?

Yes. The underlying idea is that, even if you have activated the styling setting of both digits & letters, you will typically not want to have each and every number in a document to be styled like that — there will always be numbers that should simply be shown in digits.

If you want to force-apply that styling to number-datafields, then you have to use @dynamic-fullnr.

See Locale styling – Help, which explains that the styling setting actually only affects:

  • duration type datafields
  • number, floating point number and currency type datafields included in the dynamic full number function
  • numbers surrounded by underscores (e.g. _5_) in the clause text

Thank you Maarten, makes sense, indeed!