Table cell padding

Is there any way to adjust table cell padding? I’ve got a signature block in table form but the left padding on the first column doesn’t line up with the text above the table. Here’s my code:

||% width 45 %||
||% bold true % {#disclosing-party^legal-person = true: On behalf of #disclosing-party | = false: #Disclosing-party} ||
||%signature% Signature:||
||Name: {#disclosing-party^legal-person = true: #disclosing-party^representative-name | = false: #disclosing-party^name}||
||Position: #disclosing-party^representative-function||{#disclosing-party^legal-person = true}

||% width 45 %||
||% bold true % {#recipient^legal-person = true: On behalf of #recipient | = false: #Recipient} ||
||%signature% Signature:||
||Name: {#recipient^legal-person = true: #recipient^representative-name | = false: #recipient^name}||
||Position: #recipient^representative-function||{#recipient^legal-person = true}

And here’s the output:


We currently don’t allow specifying the cell padding, but it’s not difficult to add. it’s already on the roadmap, I’ll prioritize it a bit more.

As a workaround, you could perhaps put the “Confirming the aforementioned, …” in a first row of your table (containing one merged cell)?

Thanks Maarten, good to know it’s on the roadmap. For now I think I’ll put the “Confirming …” line as the first row of the table and force a page break before. It’s common for execution pages to be separate from the body.

But now when use the special code % page break before % it doesn’t seem to affect the PDF output. Here’s the coding:

% page break before %
|| % align left % ||
||~Confirming the aforementioned~, @plural(#party) have properly concluded #°agreement.||

Here’s what I see in Assemble Document:


And here’s what I get in PDF output:


Any idea why the page break isn’t happening in the PDF?

The problem is that % page break before % is paragraph markup (i.e., layout stuff) that is added to a paragraph’s content (technically, this causes MS Word to add a “Page Break Before” setting to a paragraph, so it’s not a physical page break like you get when hitting Ctrl-Enter in MS Word).

However, in ClauseBase, your paragraph does not contain anything, so there is nothing to do, so the software treats your paragraph as irrelevant whitespace, and essentially ignores it, and thereby also ignores the page break setting.

It’s probably better if the software would produce an error message for this (I’ll look into this), but in the meantime you can easily resolve this problem by adding a @void. As suggested by its name, @voiddoes not really do something — it’s purpose in life is to act as a filler in paragraphs that do not really do anything else.


This is the dialog box in MS Word that contains that setting.


By the way, another way to solve it is by insert a @page-break instead of the % page break before %. The @page-break does effectively insert a physical pagebreak (= similar to what Ctrl-Enter in Word produces)

The @page-break code works perfectly, thanks!

In this weekend’s update to the server, a cell padding setting will be available.

You can either define it through the user interface (see screenshot below), or through % cell padding left 1cm % (or top, right or bottom).


By the way, another cool new feature is the table’s left indentation. This can either be set to a hardcoded amount (calculated from the paper’s left margin), or a relative amount calculated from the left indent of a preceding paragraph (heading and/or body paragraph). This allows tables to automatically adapt their left indent based on their level in the document — something which needs to be manually done in Word.